11.12.2017, 06:57 UTC+1  

You are not logged in.

 

Steak21

Recruit

Posts: 4

Awards: 0 / 24

1

08.08.2009, 10:43

HUD messed up, classes not appearing.. help? (Not Resolved)

Hello, im new here.
Anyways, i installed BF2 on my 32 bit windows vista computer and everything works fine exept, When i need to pick a class, i only have the first 3 classes, the rest, are invisible. They are there, but they are invisible.
I can pick the classes come that are invisible, but i have to guess where they are.
Another thing is, text is sometimes a dark grey and bold and makes it hard for me to read it.
And the last problem i have noticed, is that some of the text i cant see at all sometimes, or the commander icons on the command screen (artilery, UAV ect...)

I will post screenshots later if people need to see what im talking about to answer.
Thanks in advance =)

This post has been edited 1 times, last edit by "Steak21" (09.08.2009, 19:32)


SkAnKwOn

Walk'n'skanK

Posts: 1,161

Awards: 7 / 24

Thanks: 77 / 80

2

08.08.2009, 13:02

Hi and welcome here.
TBH I've not heard of this problem before. It sounds like graphics problems.
What card are you using, (in fact post ur specs pls)? How up to date are the drivers? 9 times out of 10, updating GFX drivers sorts odd problems like this. Although (just to confuse matters), some people are reporting problems with newer Nvidia drivers ..
°º¤º°°º¤º°

Steak21

Recruit

Posts: 4

Awards: 0 / 24

3

08.08.2009, 13:21

Hi and welcome here.
TBH I've not heard of this problem before. It sounds like graphics problems.
What card are you using, (in fact post ur specs pls)? How up to date are the drivers? 9 times out of 10, updating GFX drivers sorts odd problems like this. Although (just to confuse matters), some people are reporting problems with newer Nvidia drivers ..


OK.
But before i post my specs, i should mention that it worked fine when i had windows XP on this computer. Anyways here are my specs:
Intel Core 2 Duo CPU T5250 @ 1.50GHz
2.00 GB RAM
Video card: Moblie Intel 965 Express Chipset Family (Version 7.15.0010.1666)
Aprox. 358 MB Video Card Memory
Resolution: 1280x800

Yeah, so thats my specs, but i did some research and someone said they had to edit bf2.exe and set the value to 0 using regedit. But, i dont think its possible to edit bf2.exe in regedit.. :mellow:

Posts: 47

Awards: 0 / 24

4

08.08.2009, 14:28

Did u try adjusting resolution to some more common? (1280*800>1280*1024)or lower even> 1024 range..



:unsure: Not sure but I can imagine the screen layout is messed up at 1280*800 :unsure:
:yes: Happy Hunting :yes:

This post has been edited 1 times, last edit by "MedicalDude" (08.08.2009, 14:39)


Steak21

Recruit

Posts: 4

Awards: 0 / 24

5

08.08.2009, 15:41

but it used to work perfectly on windows xp and my resolution was at 1280x800? :(
Anyways i tried, and nope, i still get the same problem :dry:

Help please?

EDIT: Okay, well i got the screen shots.
Here they are:





Theres more problems than just that too..

This post has been edited 3 times, last edit by "Steak21" (09.08.2009, 09:45)


FlyOrDie

Where have my stars gone?

Posts: 1,358

Awards: 0 / 24

Thanks: 3 / 0

6

10.08.2009, 02:59

Set the resolution down as to 800*600. Integrated graphics aren't meant to play games well... You have an Inspiron 1525 laptop don't you?
Intel Core i7 2600 @ 3.4GHZ
Kingston HyperX T1 2133mhz 8GB
2 x Powercolor 6870 1GB
ASUS P8P67 Deluxe Mobo
2TB WD Caviar Black 7200RPM
Coolermaster HAF X case
Silverstone Strider 1000W PSU
Razer Deathadder mouse
Razer Blackwidow keyboard
Roccat Kave 5.1 headset
AOC 24" + Samsung 23" screens
Razer Goliathus mousepad

Steak21

Recruit

Posts: 4

Awards: 0 / 24

7

10.08.2009, 06:05

no, my computer is a acer aspire 5920.
So, to fix this problem to 800*600 on my computer or in the game?

FlyOrDie

Where have my stars gone?

Posts: 1,358

Awards: 0 / 24

Thanks: 3 / 0

8

11.08.2009, 02:51

Well try that at first... have you tried reinstalling?
Intel Core i7 2600 @ 3.4GHZ
Kingston HyperX T1 2133mhz 8GB
2 x Powercolor 6870 1GB
ASUS P8P67 Deluxe Mobo
2TB WD Caviar Black 7200RPM
Coolermaster HAF X case
Silverstone Strider 1000W PSU
Razer Deathadder mouse
Razer Blackwidow keyboard
Roccat Kave 5.1 headset
AOC 24" + Samsung 23" screens
Razer Goliathus mousepad

Posts: 6

Awards: 0 / 24

9

19.10.2009, 06:36

im having the same problem and i have almost the same specs as him just a tiny bit better, ive uninstalled and i just reinstalled and the same thing nothing better ive tried setting diffrent resolution ingame and nothing

FlyOrDie

Where have my stars gone?

Posts: 1,358

Awards: 0 / 24

Thanks: 3 / 0

10

20.10.2009, 05:13

Post ur graphics card please if you dont know how to find the Details look below. Update ur graphics drivers is what I recommend.

This applys to Vista and XP

Control Panel -> System -> Hardware Tab -> Device Manager -> Expand Display Adapters and tell me whats there!
Intel Core i7 2600 @ 3.4GHZ
Kingston HyperX T1 2133mhz 8GB
2 x Powercolor 6870 1GB
ASUS P8P67 Deluxe Mobo
2TB WD Caviar Black 7200RPM
Coolermaster HAF X case
Silverstone Strider 1000W PSU
Razer Deathadder mouse
Razer Blackwidow keyboard
Roccat Kave 5.1 headset
AOC 24" + Samsung 23" screens
Razer Goliathus mousepad

Posts: 6

Awards: 0 / 24

11

20.10.2009, 08:30

Intel Core2 Duo CPU T7100 @ 1.80GHz
Mobile Intel 965 Express Chipset Family
2.0GB RAM

(Chipset was the only divice under that tab so i gave a little more info, i can also post a Dxlog)

the screen shot from the other person having the same problem is 100% same problem i have nothing diffarent and i am running the game on 800*600 ive changed the res on my laptop and ingame hoping a odd combo might fix it but nothing...my graphic card is up todate running the newest Intel Graphics Media Accelerator Driver, i have direct-x 10 but the game wants me to run 9.0c so im not sure if that has somthing to do with it? would it fix anything if i uninstalled and reinstalled ignoring the direct-x 9.0c installer? im not sure if direct-x 9.0c is better then 10 since the c... but yeah hopfully we can get this problem fixed. EA is completely ignoring this problem and giving no help what soever to me or anyone else from what ive seen

FlyOrDie

Where have my stars gone?

Posts: 1,358

Awards: 0 / 24

Thanks: 3 / 0

12

21.10.2009, 02:11

Im out of ideas man... Sorry I cant help...
Intel Core i7 2600 @ 3.4GHZ
Kingston HyperX T1 2133mhz 8GB
2 x Powercolor 6870 1GB
ASUS P8P67 Deluxe Mobo
2TB WD Caviar Black 7200RPM
Coolermaster HAF X case
Silverstone Strider 1000W PSU
Razer Deathadder mouse
Razer Blackwidow keyboard
Roccat Kave 5.1 headset
AOC 24" + Samsung 23" screens
Razer Goliathus mousepad

kris5454

Recruit

Posts: 8

Awards: 0 / 24

13

23.11.2009, 23:50

so anny boty knowe this problem i got it nowe after i instald win7

FlyOrDie

Where have my stars gone?

Posts: 1,358

Awards: 0 / 24

Thanks: 3 / 0

14

25.11.2009, 02:59

Terrible English, but I can understand it. It seems the graphics card is refusing to load everything. Try updating drivers... Thats my very last idea.
Intel Core i7 2600 @ 3.4GHZ
Kingston HyperX T1 2133mhz 8GB
2 x Powercolor 6870 1GB
ASUS P8P67 Deluxe Mobo
2TB WD Caviar Black 7200RPM
Coolermaster HAF X case
Silverstone Strider 1000W PSU
Razer Deathadder mouse
Razer Blackwidow keyboard
Roccat Kave 5.1 headset
AOC 24" + Samsung 23" screens
Razer Goliathus mousepad

kris5454

Recruit

Posts: 8

Awards: 0 / 24

15

25.11.2009, 06:11

well i am from denmark so my englis sucks

i updated but it dit not help wen i was running vista the game was working fine

FlyOrDie

Where have my stars gone?

Posts: 1,358

Awards: 0 / 24

Thanks: 3 / 0

16

26.11.2009, 00:12

Ok NOW im out of ideas...
Intel Core i7 2600 @ 3.4GHZ
Kingston HyperX T1 2133mhz 8GB
2 x Powercolor 6870 1GB
ASUS P8P67 Deluxe Mobo
2TB WD Caviar Black 7200RPM
Coolermaster HAF X case
Silverstone Strider 1000W PSU
Razer Deathadder mouse
Razer Blackwidow keyboard
Roccat Kave 5.1 headset
AOC 24" + Samsung 23" screens
Razer Goliathus mousepad

xJTv

Recruit

Posts: 1

Awards: 0 / 24

17

30.12.2011, 08:36

Hello
Steak21,
I've seen your post about the invisible hud in Battlefield 2 and I think i had found a solution for your problem. I'm not sure if it will work on your PC. I'm not sure if you have to download other files. So here are the steps.


1)Download the files that i'm going to provide you.
[url]http://www.strategyinformer.com/pc/battlefield2/mod/39950.html[/url]
[url]http://www.strategyinformer.com/pc/battlefield2/mod/39951.html[/url]
[url]http://www.strategyinformer.com/pc/battlefield2/mod/39952.html[/url]

2)After installing the "Mod" go ahead and open it [Do not open the original "Battlefield 2" Game just open the mod icon "Forgotten Hope 2"]
____________________________________________________________________________________________________________________________________

You could play "Forgotten Hope 2" if your want to but if your not going to play that mod go to Custom Games in the menu, select Battlefield 2,and
then "Activate" the game.

Once you are on the original battlefield 2 game go ahead and select a map and the classes should be there and also your hud.

[Downside is when you open the battlefield 2 icon in your desktop and you play a match your class your classes will disappear and also your hud.
Remember follow the steps that i provided you with.


Your friend, xJTv
P.S- If this works i would want you to spead the word. I would kindly appreciate it

bleki

Recruit

Posts: 1

Awards: 0 / 24

18

10.01.2014, 20:07

Helo,
I had the same problem with the hud, until I found out that the solution is:
Computers with onboard intel graphics have a driver feature called "peak processing" ("csúcsfeldolgozás" on the picture)
http://www.imagebam.com/image/974f8c300264538
The value have to be "application settings" or "default settings" not "allow software processing".